Back to overview
Downtime

Service Disruption Due to AWS Outage

Oct 20 at 10:00am CEST
Affected services
Public Website
Platform

Resolved
Oct 20 at 12:39pm CEST

All systems have remained stable for a few hours, and we’ve observed no further impact. The earlier disruption caused by the AWS outage has been fully resolved. We’ll continue to monitor performance, but normal operations have been restored.

Updated
Oct 20 at 10:26am CEST

Our platform is back online and functioning normally. Please note that AWS is still reporting partial service degradation, which could cause brief interruptions. We’ll continue to keep a close eye on performance and update this page if conditions change.

Created
Oct 20 at 10:00am CEST

We are currently experiencing a service disruption caused by an ongoing AWS infrastructure outage. Our team is monitoring the situation closely and working to restore full functionality as soon as AWS services return to normal. We’ll provide updates here as more information becomes available.